[FAQ ID: 439]Windows 7 Bulit-in PPPoE Wizard Fails with Error Code 651

Suitable for: ADSL2+ Modem Routers, ADSL2+ Modem

When using Windows 7 built-in PPPoE wizard with a modem working in bridge mode, it fails and error code 651 appears. The similar problem happens on Windows Vista or previous versions as well. For example, Error code 678 on Windows XP is equivalent to error code 651 on Windows 7.
 
About that problem, if it happens to you, it is highly recommended to adopt following attempts. Take TD-8616 as an example.
 
1.    Confirm ADSL indicator on TD-8616 is solid on.
If it is flashing on or off, excluding a splitter issue, please check the phone line with your ISP and make it synchronized.
Since maybe it is not an ISP problem, please hard reset TD-8616. If ADSL light is still not on, please RMA it.
If ADSL light is solid on but the problem continues, you may go to our website or contact us to get the latest firmware and upgrade your modem.
 
2.    Set up a new PPPoE connection on your Windows 7.
Click here to find how to set up PPPoE connection of Windows 7.
If necessary, after testing this new connection works, delete the old connection to avoid any future confusion over which connection should be used.
 
3.    Update rasppoe.sys file and NIC driver.
The root of the problem is believed to be caused by the RAS PPPoE file raspppoe.sys found in the folder C:\Windows\System32\Drivers. To fix this problem, we will have to replace the file raspppoe.sys with a new one. 
1)     Try to copy the file from your friend’s computer which has Windows 7 installed. Alternatively, you can download the raspppoe.sys file from this site (thanks to the author). 
2)     After you get the file, before pasting it into C:\Windows\System32\Drivers, be sure that you rename the original file to something like raspppoe_ori.sys, so that if something weird happen you have a backup of your original file. 
3)     Paste the new raspppoe.sys into the directory after you’ve renamed the original file. Try to connect your modem and it should work fine now.

4.    Boot the computer in Safe mode. Disable anti-virus software.
It is suggested to boot the computer in safe mode with networking and check if you are able to connect to the internet without any issues, safe mode starts Windows with a limited set of files and drivers. Startup programs do not run in safe mode, and only the basic drivers needed to start Windows are installed, follow the steps to boot the computer in safe mode with networking:
1)     Restart your computer if it is powered on.
2)     Tap the F8 key after your computer initially powers on.
3)     Once you see the Advanced Boot Options menu you can stop tapping.
4)     Use the up/down arrow keys to highlight your selection.
5)     Select Safe Mode with Networking and press Enter.
6)     You should see drivers loading, and then please wait.
7)     You should then be at the Welcome Screen.
8)     Logon to your computer using an account with Administrator privileges.
If this step fails then try Disabling Firewall/Security Software if any.
 
5.    Power cycling your Modem and Router might resolve the problem, here are the steps:
1)     Save all your current work, close all open applications, then shut down your computer. Wait for a minute.
2)     Turn your Router off and wait for a couple of minutes.
3)     Turn off your modem.
4)     Disconnect all the Ethernet cables that are connected to the router and modem and the PC.
5)     Reconnect them and ensure that there are no loose connections in between them.
6)     Now, switch on your PC and let it boot.
7)     Switch on the modem first and after it gets initialized, switch on the router.

6.    Modify Link Speed & Duplex Mode to be 100Mbps Full Duplex and disable IPv6.
1)    Go to control panel, Network and Internet, Network and Sharing Center. On you left side, go to change adapter settings.
2)    Right click on Local Area connection and go to Properties.
3)    Click on Configure. Choose Advance tab. Select Link Speed & Duplex from the Property. Modify Value to be 100Mbps Full Duplex. Press OK.
 
In Local Area Connection Properties Window, uncheck Internet Protocol Version 6 (TCP/IPv6). Press OK to disable IPv6.
If above attempts fails to solve your problem, please feel free to contact with us, we will try our best to help you!

About how to solve the Error 651, we also refer to the answer from Microsoft support:

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/error-651-in-windows-7/65077414-15f8-450b-bd19-5cce9a57fcf0?auth=1